Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119416
Published:October 30, 2026
Updated:November 04, 2026
CakePHP through 5.4.3 contains an improper cookie domain validation vulnerability in the Http Client CookieCollection that allows malicious servers to receive and plant cookies by abusing unanchored suffix matching. Attackers controlling a host such as one ending in a victim domain suffix, or sending Set-Cookie Domain values for unrelated hosts, can steal session cookies or inject cookies into shared client cookie jars.
Affected Packages
https://github.com/cakephp/cakephp.git (GITHUB):
Affected version(s) >=3.0.0-alpha2 <4.6.6 || >=4.0.0-alpha1 <4.6.6
Fix Suggestion:
Update to version 4.6.6
https://github.com/cakephp/cakephp.git (GITHUB):
Affected version(s) >=5.4.0-RC1 <5.4.4
Fix Suggestion:
Update to version 5.4.4
https://github.com/cakephp/cakephp.git (GITHUB):
Affected version(s) >=5.0.0-beta1 <5.2.16
Fix Suggestion:
Update to version 5.2.16
https://github.com/cakephp/cakephp.git (GITHUB):
Affected version(s) >=5.3.0-RC1 <5.3.8
Fix Suggestion:
Update to version 5.3.8
cakephp/http (PHP):
Affected version(s) >=4.0.0-RC1 <4.6.6
Fix Suggestion:
Update to version 4.6.6
cakephp/http (PHP):
Affected version(s) >=5.0.0-beta1 <5.3.8 || >=5.3.0-RC1 <5.3.8
Fix Suggestion:
Update to version 5.3.8
cakephp/http (PHP):
Affected version(s) >=5.4.0-RC1 <5.4.4
Fix Suggestion:
Update to version 5.4.4
cakephp/cakephp (PHP):
Affected version(s) >=5.3.0-RC1 <5.3.8
Fix Suggestion:
Update to version 5.3.8
cakephp/cakephp (PHP):
Affected version(s) >=4.0.0-alpha1 <4.6.6 || >=3.0.0-alpha2 <4.6.6
Fix Suggestion:
Update to version 4.6.6
cakephp/cakephp (PHP):
Affected version(s) >=5.0.0-beta1 <5.2.16
Fix Suggestion:
Update to version 5.2.16
cakephp/cakephp (PHP):
Affected version(s) >=5.4.0-RC1 <5.4.4
Fix Suggestion:
Update to version 5.4.4
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.8
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Origin Validation Error
EPSS
Base Score:
0.18