CVE-2026-119424
Published:October 30, 2026
Updated:November 04, 2026
OPNsense core before 26.7.8 contains a configuration line injection vulnerability that allows authenticated users with wireless-edit privilege to inject directives by embedding CR/LF characters in WPA fields. Attackers can place newlines in wpa.identity, wpa.passphrase, or RADIUS shared secrets to append arbitrary wpa_supplicant or hostapd directives loaded by root-run daemons.
Affected Packages
https://github.com/opnsense/core.git (GITHUB):
Affected version(s) >=15.1 <26.7.8 || >=16.1 <26.7.8 || >=17.1 <26.7.8 || >=18.1 <26.7.8 || >=19.1 <26.7.8 || >=20.1 <26.7.8 || >=21.1 <26.7.8 || >=22.1 <26.7.8 || >=23.1 <26.7.8 || >=24.1 <26.7.8 || >=25.1 <26.7.8 || >=26.1 <26.7.8Fix Suggestion:
Update to version 26.7.8Related Resources (9)
Do you need more information?
Contact UsCVSS v4
Base Score:
6.1
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.8
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Improper Neutralization of CRLF Sequences
EPSS
Base Score:
0.42