Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119721
Published:October 30, 2026
Updated:November 04, 2026
Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields without block length checks. Attackers can supply a crafted .blend file with short ID blocks that, when browsed or appended from, causes heap over-reads leading to crashes or heap memory disclosure.
Affected Packages
https://github.com/blender/blender.git (GITHUB):
Affected version(s) >=v2.25 <v4.5.15 || >=2.72b <v4.5.15 || >=v3.0.0 <v4.5.15 || >=v4.0.0 <v4.5.15
Fix Suggestion:
Update to version v4.5.15
https://github.com/blender/blender.git (GITHUB):
Affected version(s) >=v5.0.0 <v5.2.3
Fix Suggestion:
Update to version v5.2.3
bpy (PYTHON):
Affected version(s) >=5.0.0 <5.2.3
Fix Suggestion:
Update to version 5.2.3
bpy (PYTHON):
Affected version(s) >=4.2.0 <4.5.15
Fix Suggestion:
Update to version 4.5.15
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.9
Attack Vector
LOCAL
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.1
Attack Vector
LOCAL
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Out-of-bounds Read
EPSS
Base Score:
0.17