Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119729
Published:October 30, 2026
Updated:November 04, 2026
A flaw was found in GStreamer. An integer overflow vulnerability in the AV1 LEB128 variable-length integer parser allows a remote attacker to cause a crash in applications that process AV1 media content. By crafting a malformed AV1 bitstream containing an invalid LEB128-encoded value, an attacker can cause integer overflow in the parser, resulting in incorrect length values being used during stream processing, which can lead to a denial of service.
Affected Packages
gst-plugins-bad (CONDA):
Affected version(s) >=1.18.4 <1.28.2
Fix Suggestion:
Update to version 1.28.2
gst-plugins-base (CONDA):
Affected version(s) >=1.26.2 <1.28.2
Fix Suggestion:
Update to version 1.28.2
https://github.com/GStreamer/gstreamer.git (GITHUB):
Affected version(s) >=gst-plugins-bad-1.17.1 <1.28.2 || >=1.19.3 <1.28.2
Fix Suggestion:
Update to version 1.28.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Integer Overflow or Wraparound
EPSS
Base Score:
0.40