Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-120207
Published:October 31, 2026
Updated:November 04, 2026
Thelia Page Module before 2.0.4 contains a cross-site request forgery vulnerability that allows remote attackers to delete page tags, documents and images by abusing back-office delete routes lacking CSRF tokens and permission checks. Attackers can lure a logged-in administrator into navigating to crafted GET requests that walk sequential ids, removing TheliaLibrary images, their files and variants across pages, products and categories.
Affected Packages
https://github.com/thelia-modules/Page.git (GITHUB):
Affected version(s) =0.0.9 <2.0.4 || >=1.0.1 <2.0.4 || >=2.0.0 <2.0.4
Fix Suggestion:
Update to version 2.0.4
thelia/page-module (PHP):
Affected version(s) >=1.0.1 <2.0.4 || =0.0.9 <2.0.4 || >=2.0.0 <2.0.4
Fix Suggestion:
Update to version 2.0.4
Do you need more information?
Contact Us
CVSS v4
Base Score:
7
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
ACTIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
HIGH
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.1
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
LOW
Weakness Type (CWE)
Cross-Site Request Forgery
EPSS
Base Score:
0.20