CVE-2026-57184
Published:October 26, 2026
Updated:November 04, 2026
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, insufficient bounds checking in the "chan_ooh323" "Q.931" "information-element parser" permits an "out-of-bounds read" that may allow an unauthenticated attacker to crash Asterisk using carefully crafted "setup packets". The "chan_ooh323" addon channel driver must be explicitly compiled and installed, which is not the default, and its port must be publicly reachable. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Affected Packages
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-22.8-cert1-rc1 <certified-22.8-cert3Fix Suggestion:
Update to version certified-22.8-cert3https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=23.0.0-rc1 <23.4.1Fix Suggestion:
Update to version 23.4.1https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=1.8.0-beta1 <20.20.1 || >=10.0.0-beta1 <20.20.1 || >=11.0.0-beta1 <20.20.1 || >=12.0.0-alpha1 <20.20.1 || >=13.0.0-beta1 <20.20.1 || >=14.0.0-beta1 <20.20.1 || >=15.0.0-beta1 <20.20.1 || >=16.0.0-rc1 <20.20.1 || >=17.0.0-rc1 <20.20.1 || >=18.0.0-rc1 <20.20.1 || >=19.0.0-rc1 <20.20.1 || >=20.0.0-rc1 <20.20.1Fix Suggestion:
Update to version 20.20.1https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=22.0.0-rc1 <22.10.1Fix Suggestion:
Update to version 22.10.1https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-18.9-cert4 <certified-20.7-cert11 || >=certified-20.7-cert1-rc1 <certified-20.7-cert11Fix Suggestion:
Update to version certified-20.7-cert11https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=21.0.0-rc1 <21.12.3Fix Suggestion:
Update to version 21.12.3Related Resources (16)
Do you need more information?
Contact UsCVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Weakness Type (CWE)
Out-of-bounds Read
EPSS
Base Score:
0.56